Designer Workflow 2010: Unable to load workflow actions from the server. Please contact your server administrator

I needed to make some modifications to one of my sites with custom SharePoint designer workflows. I open SharePoint Designer, click Workflows, click my workflow and I get Message box that

Unable to load workflow actions from the server

Investigation of the error – steps:

  1. Turn on Failed Request Tracing on IIS – this did not show any more specific error, only 500 Internal Server Error on SharePoint web service call
  2. Checking ULS, nothing logged there
  3. Created empty site collection with Publishing feature and workflow – workflows open correctly
  4. Same site restored to another server – workflows open correctly
  5. I do not have any custom developed Workflow actions!
  6. I compared farm solution on one server and another server. I see some differences in solutions. I think, can have something to do with installed solutions. There is one suspicious looking solution there that we once tried to use to move site with workflows and forms from one farm to another (by saving site as WSP package). It is installed globally. I know we abandoned idea as it fad site backup/restore instead. I retract this solution. I go back to designer and find workflow working.

So, conclusion:

Checking custom solutions is another checkpoint in investigation of this nasty error. I have read tones of msdn threads on this one, and causes can be different, but Designer will always give you same error message. My solution was generated from saving site as template (WSP package). It was site with custom workflows and some infopath forms deployed to this site as content type.

4 Responses to “Designer Workflow 2010: Unable to load workflow actions from the server. Please contact your server administrator”

  1. Johan

    Had the same problem, and when I looked throu deplyed solutions I too found a suspect little fella, once I restracted it, the problem was gone:)

    thanks, you got me on track!

    Reply
  2. TomH

    Thank you! It was a custom template that was causing me the same problem with the workflow error. Took two days to figure it out. Once i replaced the site template, workflow capability returned.

    Reply
  3. Ali Yasir

    Hi ,
    I cannot afford to retract the already deployed farm solution. No doubt if I remove that solution my workflow works but I need to have that farm solution as well.
    What to do ?

    Reply
    • horsik

      Ali, in my case solution was not used anymore, it was solution that we exported to move site across to different server. So once it was there, it could be removed anyway. We did not end up using this method, because site was ot fullly functional after migration. We used site backup and restoration instead. You will have to retract solution, if it makes some configuration xml markup corrupted – there is no other way to fix it that I know of. Retracting solution is not such a scarry thing, you can always deploy again. Let me know how you go with it

      Reply

Leave a Reply to TomH

Click here to cancel reply.